Skip to main content
VulnerabilityPublished

CVE-2026-30946: parse-server · Unthrottled Resource Allocation

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 9.5.2-alpha.2 or 8.6.15 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.2, 8.6.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.2 or 8.6.15; parse-server to 8.6.15.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.2
Fixed in
  • 9.5.2-alpha.2
parse-communityparse-serverAffected
  • <8.6.15
Fixed in
  • 8.6.15
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.15
Fixed in
  • 8.6.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-30946, organizations should immediately upgrade parse-server to version 8.6.15 or 9.5.2-alpha.2 or later, where the vulnerability is fixed. In addition, implement the following practical measures: 1) Deploy API rate limiting and throttling at the network or application layer to restrict the number and complexity of incoming queries. 2) Use Web Application Firewalls (WAFs) with custom rules to detect and block suspicious query patterns targeting REST and GraphQL endpoints. 3) Monitor resource utilization metrics (CPU, memory, database connections) closely to identify anomalous spikes indicative of abuse. 4) Restrict public exposure of parse-server APIs where possible, using network segmentation, VPNs, or IP whitelisting to limit access to trusted clients. 5) Employ query complexity analysis tools or middleware that can reject overly complex or nested queries before processing. 6) Maintain an incident response plan to quickly isolate and remediate affected systems in case of an attack. These steps complement upgrading and help reduce the attack surface and impact of potential exploitation.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.

References

Community reviews

Loading reviews…