Skip to main content
VulnerabilityPublished

CVE-2026-32264: craftcms cms · Unsafe Reflection

Affects craftcms cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 5.9.11 or 4.17.5 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.11, 4.17.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade craftcms cms to 5.9.11 or 4.17.5.

Affected software

ProductAffectedFixed in
craftcmscmsAffected
  • >=5.0.0-RC1 <5.9.11
Fixed in
  • 5.9.11
craftcmscmsAffected
  • >=4.0.0-RC1 <4.17.5
Fixed in
  • 4.17.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate patching: Upgrade Craft CMS installations to version 4.17.5 or later, or 5.9.11 or later, where the vulnerability is fixed.
  2. Restrict administrator access: Limit control panel administrator permissions strictly to trusted personnel and enforce strong authentication mechanisms such as multi-factor authentication (MFA).
  3. Disable allowAdminChanges: If not required, disable the allowAdminChanges setting to reduce the attack surface.
  4. Monitor logs: Implement detailed logging and monitoring of control panel activities to detect suspicious behavior indicative of exploitation attempts.
  5. Harden server environment: Employ web application firewalls (WAFs) with rules to detect and block unusual requests targeting the vulnerable controllers.
  6. Conduct security audits: Regularly review CMS configurations and code for unsafe reflection patterns or other insecure coding practices.
  7. Backup data: Maintain regular, secure backups of CMS data and configurations to enable recovery in case of compromise.
  8. Educate administrators: Train CMS administrators on secure configuration and the risks associated with privilege misuse. These measures combined will reduce the likelihood of exploitation and limit the impact if an attack occurs.

Description

CVE-2026-32264 is a high-severity remote code execution vulnerability in Craft CMS versions 4.0.0-RC1 to before 4.17.5 and 5.0.0-RC1 to before 5.9.11. It involves unsafe reflection via externally controlled input in ElementIndexesController and FieldsController, allowing behavior injection.

References

Community reviews

Loading reviews…