Skip to main content
VulnerabilityPublished Updated

CVE-2026-32635: @angular compiler · Cross-site Scripting

Affects @angular compilerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High · fixed in 22.0.0-next.3 : patch @angular compiler soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 22.0.0-next.3, 21.2.4, 20.3.18 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade compiler and core to 22.0.0-next.3, 21.2.4, 20.3.18 or 19.2.20; @angular/compiler to 21.2.4, 20.3.18 or 19.2.20.

Affected software

ProductAffectedFixed in
@angularcompilerAffected
  • >=22.0.0-next.0 <22.0.0-next.3
Fixed in
  • 22.0.0-next.3
@angularcompilerAffected
  • >=21.0.0-next.0 <21.2.4
Fixed in
  • 21.2.4
@angularcompilerAffected
  • >=20.0.0-next.0 <20.3.18
Fixed in
  • 20.3.18
@angularcompilerAffected
  • >=17.0.0.next.0 <19.2.20
Fixed in
  • 19.2.20
@angularcoreAffected
  • >=22.0.0-next.0 <22.0.0-next.3
Fixed in
  • 22.0.0-next.3
@angularcoreAffected
  • >=21.0.0-next.0 <21.2.4
Fixed in
  • 21.2.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32635, organizations should immediately upgrade Angular to the fixed versions: 22.0.0-next.3, 21.2.4, 20.3.18, or 19.2.20, or later. Developers should audit their codebases for usage of Angular’s internationalization on security-sensitive attributes (e.g., i18n-href) and avoid binding untrusted user input to these attributes. Implement strict input validation and sanitization on all user-generated content before binding it to the DOM, even when using Angular’s built-in mechanisms. Employ Content Security Policy (CSP) headers to restrict script execution sources and reduce the impact of potential XSS attacks. Conduct thorough security testing, including static and dynamic analysis, focusing on internationalization features and attribute bindings. Educate developers on secure coding practices related to Angular’s i18n features and the risks of bypassing sanitization. Monitor web application logs and user reports for suspicious activity indicative of XSS exploitation attempts. Finally, maintain an up-to-date inventory of Angular versions in use to ensure timely patching of future vulnerabilities.

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.

References

Community reviews

Loading reviews…