CVE-2026-33218: nats-server · Improper Input Validation
Affects nats-serverSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 2.12.6 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.6, 2.11.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade nats-server to 2.12.6; nats-io/nats-server to 2.11.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nats-ionats-server | Affected
| Fixed in
|
GitHubnats-io/nats-serverpkg:github/nats-io/nats-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in nats-server versions 2.11.15 and 2.12.6. Users should upgrade to these or later versions to remediate the vulnerability. If upgrading is not immediately possible, mitigating actions include disabling leafnode support if it is not required or restricting network access to the leafnode port to trusted sources. Red Hat notes that no mitigation fully meets their criteria for ease of use and stability, so upgrading is the recommended approach.
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, disable leafnode support if not needed or restrict network connections to the leafnode port, if plausible without compromising the service offered.
References
- github.com/nats-io/nats-server/security/advisories/GHSA-vprv-35vv-q339 (opens in a new tab)
- advisories.nats.io/CVE/secnote-2026-10.txt (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-33218 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2451450 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33218.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22347 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:23345 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21769 (opens in a new tab)