Skip to main content
VulnerabilityPublished

CVE-2026-33409: parse-server · Improper Authentication

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.0 High : upgrade to 9.6.0-alpha.41 or 8.6.52 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.41, 8.6.52
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.41 or 8.6.52; parse-community/parse-server to 8.6.52.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.41
Fixed in
  • 9.6.0-alpha.41
parse-communityparse-serverAffected
  • <8.6.52
Fixed in
  • 8.6.52
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.52
Fixed in
  • 8.6.52

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-33409, organizations should: 1) Immediately upgrade parse-server to version 8.6.52 or later, or 9.6.0-alpha.41 or later, where the vulnerability is patched. 2) Verify and ensure the server configuration option allowExpiredAuthDataToken is set to false unless there is a compelling reason to enable it, as the vulnerability only manifests when this option is true. 3) Audit existing deployments to identify any usage of third-party authentication providers and confirm that provider IDs are not exposed or easily guessable. 4) Implement strict access controls and monitoring around authentication-related logs to detect suspicious login attempts or anomalies. 5) Educate development and operations teams about the risks of enabling allowExpiredAuthDataToken and enforce secure configuration management practices. 6) Consider additional compensating controls such as multi-factor authentication (MFA) at the application layer to reduce the impact of compromised credentials or session tokens. 7) Regularly review and update dependencies and monitor security advisories related to parse-server and third-party authentication integrations. These steps go beyond generic advice by focusing on configuration auditing, secure deployment practices, and layered defense.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0

References

Community reviews

Loading reviews…