Skip to main content
VulnerabilityPublished

CVE-2026-33421: parse-server · Incorrect Authorization

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 9.6.0-alpha.42 or 8.6.53 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.42, 8.6.53
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.42 or 8.6.53; parse-community/parse-server to 8.6.53.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.42
Fixed in
  • 9.6.0-alpha.42
parse-communityparse-serverAffected
  • <8.6.53
Fixed in
  • 8.6.53
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.53
Fixed in
  • 8.6.53

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 8.6.53 or later, or 9.6.0-alpha.42 or later, where the vulnerability is patched. Until upgrades are applied, administrators should consider disabling the LiveQuery WebSocket interface if real-time updates are not critical to their applications. Implement strict monitoring and logging of WebSocket connections to detect unusual subscription patterns or unauthorized access attempts. Review and audit user authentication and authorization policies to limit the number of users with access to LiveQuery features. Employ network segmentation and Web Application Firewalls (WAFs) to restrict access to the parse-server backend from untrusted networks. Conduct thorough security testing and code reviews focusing on access control enforcement in real-time data interfaces. Educate developers and administrators about the risks of bypassed pointer permissions and encourage prompt patch management. Finally, consider implementing additional application-layer encryption or tokenization of sensitive data to reduce exposure risk even if unauthorized subscriptions occur.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.53 and 9.6.0, Parse Server's LiveQuery WebSocket interface does not enforce Class-Level Permission (CLP) pointer permissions (readUserFields and pointerFields). Any authenticated user can subscribe to LiveQuery events and receive real-time updates for all objects in classes protected by pointer permissions, regardless of whether the pointer fields on those objects point to the subscribing user. This bypasses the intended read access control, allowing unauthorized access to potentially sensitive data that is correctly restricted via the REST API. This issue has been patched in versions 8.6.53 and 9.6.0

References

Community reviews

Loading reviews…