CVE-2026-33538: parse-server · Uncontrolled Resource Consumption
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 9.6.0-alpha.52 or 8.6.58 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.52, 8.6.58
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.52 or 8.6.58; parse-community/parse-server to 8.6.58.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade parse-server to version 8.6.58 or later, or 9.6.0-alpha.52 or later, where this vulnerability has been patched. For organizations unable to upgrade immediately, temporary mitigations include implementing rate limiting on authentication requests to limit the number of requests with unconfigured provider names, thereby reducing the potential for resource exhaustion. Additionally, monitoring database query performance and unusual spikes in authentication requests can help detect exploitation attempts early. Applying database-level indexing on the provider field, if feasible, can reduce the cost of queries for unconfigured providers, though this may require custom modifications. Network-level protections such as web application firewalls (WAFs) can be configured to block or throttle suspicious authentication requests with unknown provider names. Finally, restricting access to parse-server endpoints to trusted IP ranges or behind VPNs can reduce exposure to unauthenticated attackers.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.58 and 9.6.0-alpha.52, an unauthenticated attacker can cause denial of service by sending authentication requests with arbitrary, unconfigured provider names. The server executes a database query for each unconfigured provider before rejecting the request, and since no database index exists for unconfigured providers, each request triggers a full collection scan on the user database. This can be parallelized to saturate database resources. This issue has been patched in versions 8.6.58 and 9.6.0-alpha.52.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-g4cf-xj29-wqqr (opens in a new tab)
- github.com/parse-community/parse-server/pull/10270 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10271 (opens in a new tab)
- github.com/parse-community/parse-server/commit/40eb442e02672986730007d0a1edb22c1c4bd357 (opens in a new tab)
- github.com/parse-community/parse-server/commit/fbac847499e57f243315c5fc7135be1d58bb8e54 (opens in a new tab)