Skip to main content
VulnerabilityPublished

CVE-2026-34595: parse-server · Type Confusion

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.7.0-alpha.18 or 8.6.70 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.7.0-alpha.18, 8.6.70
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.7.0-alpha.18 or 8.6.70; parse-community/parse-server to 8.6.70.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.7.0-alpha.18
Fixed in
  • 9.7.0-alpha.18
parse-communityparse-serverAffected
  • <8.6.70
Fixed in
  • 8.6.70
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.70
Fixed in
  • 8.6.70

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade parse-server to version 8.6.70 or later, or 9.7.0-alpha.18 or later, where the vulnerability has been patched. Until upgrade is possible, organizations should consider disabling LiveQuery subscriptions or restricting their use to trusted users only. Review and tighten class-level permissions, especially the find permission, to limit the number of users who can perform queries. Implement additional application-layer validation and monitoring to detect unusual subscription patterns that may indicate exploitation attempts. Employ network segmentation and access controls to limit exposure of parse-server instances. Regularly audit logs for suspicious LiveQuery subscription activity. Educate developers and administrators about the risks of using array-like objects in query filters and ensure input validation is robust. Finally, maintain an incident response plan to quickly address any detected exploitation.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.70 and 9.7.0-alpha.18, an authenticated user with find class-level permission can bypass the protectedFields class-level permission setting on LiveQuery subscriptions. By sending a subscription with a $or, $and, or $nor operator value as a plain object with numeric keys and a length property (an "array-like" object) instead of an array, the protected-field guard is bypassed. The subscription event firing acts as a binary oracle, allowing the attacker to infer whether a protected field matches a given test value. This issue has been patched in versions 8.6.70 and 9.7.0-alpha.18.

References

Community reviews

Loading reviews…