Skip to main content
VulnerabilityPublished

CVE-2026-3589: WooCommerce (WordPress plugin) · Cross-Site Request Forgery (CSRF)

Affects WooCommerce (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 10.5.3 : patch WooCommerce (WordPress plugin) soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.5.3, 10.4.4, 10.3.8 +49
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AutomatticWooCommerceAffected
  • >=10.5.0 <10.5.3
Fixed in
  • 10.5.3
AutomatticWooCommerceAffected
  • >=10.4.0 <10.4.4
Fixed in
  • 10.4.4
AutomatticWooCommerceAffected
  • >=10.3.0 <10.3.8
Fixed in
  • 10.3.8
AutomatticWooCommerceAffected
  • >=10.2.0 <10.2.4
Fixed in
  • 10.2.4
AutomatticWooCommerceAffected
  • >=10.1.0 <10.1.4
Fixed in
  • 10.1.4
AutomatticWooCommerceAffected
  • >=10.0.0 <10.0.6
Fixed in
  • 10.0.6

AI-suggested

To mitigate CVE-2026-3589, organizations should immediately upgrade WooCommerce to a patched version once available from Automattic. If you cannot patch yet, administrators should implement the following specific measures: 1) Restrict access to the WordPress REST API endpoints by configuring web application firewalls (WAFs) or server-level rules to block unauthorized batch requests, especially those targeting admin-level endpoints. 2) Employ strict Content Security Policy (CSP) headers and SameSite cookie attributes to reduce CSRF attack vectors. 3) Limit admin user creation permissions to trusted IP addresses or through multi-factor authentication (MFA) to reduce risk if exploitation occurs. 4) Monitor logs for unusual REST API activity or unexpected user account creations. 5) Disable batch request functionality if feasible via plugin settings or custom code hooks until patched. 6) Educate site administrators about the risk and signs of compromise. These targeted mitigations go beyond generic advice by focusing on the specific attack vector and REST API abuse inherent in this vulnerability.

Description

The WooCommerce WordPress plugin from versions 5.4.0 to 10.5.2 does not properly handle batch requests, which could allow unauthenticated users to make a logged in admin call non store/WC REST endpoints, and create arbitrary admin users via a CSRF attack for example.

References

Community reviews

Loading reviews…