Skip to main content
VulnerabilityPublished Updated

CVE-2026-4168: Tecnick TCExam · Cross-site Scripting

Affects Tecnick TCExamSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
TecnickTCExamAffected
  • =16.5.0
Fixed in–
GitHubtecnickcom/tcexampkg:github/tecnickcom/tcexamOther threatsAffected
  • <=16.5.0
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:tecnick:tcexam:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately verify their TCExam version and upgrade to the latest release where this vulnerability is fixed. If upgrading is not immediately feasible, administrators should restrict access to the /admin/code/tce_edit_group.php endpoint to trusted IPs and enforce strict authentication and authorization controls. Input validation and output encoding should be reviewed and enhanced to sanitize the 'Name' parameter and other user inputs rigorously. Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS attacks. Regularly audit administrator accounts and monitor logs for suspicious activity indicative of exploitation attempts. Educate administrators about phishing and social engineering risks that could facilitate user interaction required for exploitation. Finally, maintain an incident response plan to quickly address any detected compromise related to this vulnerability.

Description

CVE-2026-4168 is a medium severity cross-site scripting (XSS) vulnerability found in Tecnick TCExam version 16.5.0, specifically in the /admin/code/tce_edit_group.php file within the Group Handler component. The vulnerability arises from improper sanitization of the 'Name' argument, allowing remote attackers to inject malicious scripts. Exploitation requires high privileges and user interaction, and no authentication bypass is indicated. Although a public exploit exists, the vendor has indicated that the issue could not be reproduced in later versions, suggesting it has been fixed. Organizations using TCExam 16.5.0 or earlier should upgrade to the latest version to mitigate risk.

References

Community reviews

Loading reviews…