CVE-2026-44295: protobufjs protobuf.js · Code Injection
Affects protobufjs protobuf.jsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 2.0.2 or 1.2.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.2, 1.2.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade protobuf.js to 2.0.2 or 1.2.1; protobufjs-cli to 1.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| protobufjsprotobuf.js | Affected
| Fixed in
|
| protobufjsprotobuf.js | Affected
| Fixed in
|
npmprotobufjs-clipkg:npm/protobufjs-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in protobuf.js versions 1.2.1 and 2.0.2. Users should upgrade to at least these versions to remediate the issue. No additional mitigations are specified.
Description
CVE-2026-44295 is a high-severity vulnerability in protobufjs-cli, the command line add-on for protobuf.js. Before versions 1.2.1 and 2.0.2, the static code generation feature (pbjs) could produce unsafe JavaScript identifiers derived from schema-controlled names without proper sanitization. This flaw allows crafted schemas or JSON descriptors to inject unsafe code into the generated JavaScript output. The vulnerability is classified as CWE-94 (Improper Control of Generation of Code). It has a CVSS v3.