Skip to main content
VulnerabilityPublished

CVE-2026-46718: Apache Calcite · Unsafe Reflection

Affects Apache CalciteSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.42 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.42
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache to 1.42.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CalciteAffected
  • >=1.5.0 <1.42
Fixed in
  • 1.42
Mavenorg.apache.calcite/calcitepkg:maven/org.apache.calcite/calciteOther threatsAffected
  • =1.5.0
Fixed in–
MavenApache Software Foundation/org.apache.calcite:calcite-corepkg:maven/Apache Software Foundation/org.apache.calcite:calcite-coreOther threatsAffected
  • >=1.5.0 <1.42
Fixed in
  • 1.42

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Calcite to version 1.42 or later, where this vulnerability is fixed. No other remediation or temporary fixes are indicated. Patch status is confirmed by the recommendation to upgrade to 1.42.

Description

Apache Calcite versions from 1.5.0 up to but not including 1.42 contain a vulnerability involving unsafe reflection, where externally-controlled input is used to select classes or code. This can lead to limited confidentiality and integrity impacts. The issue is fixed in version 1.42.

References

Community reviews

Loading reviews…