Skip to main content
VulnerabilityPublished Updated

CVE-2026-56356: n8n · Cross-site Scripting

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium · fixed in 2.14.1 : update n8n when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.1
CNA (VulnCheck)CVSS 3.15.4
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-07-01.

Patch
Available – fixed in 2.14.1, 2.13.3, 1.123.27
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade n8n to 2.14.1, 2.13.3 or 1.123.27; n8n to 2.14.1; n8n to 2.13.3.

Affected software

ProductAffectedFixed in
n8nn8nAffected
  • >=2.14.0 <2.14.1
Fixed in
  • 2.14.1
n8nn8nAffected
  • >=2.0.0-rc.0 <2.13.3
Fixed in
  • 2.13.3
n8nn8nAffected
  • <1.123.27
Fixed in
  • 1.123.27
n8nn8nAffected
  • >=2.14.0 <2.14.1
Fixed in
  • 2.14.1
n8nn8nAffected
  • >=2.0.0-rc.0 <2.13.3
Fixed in
  • 2.13.3
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.27
  • >=2.0.0-rc.0 <2.13.3
  • >=2.14.0 <2.14.1
Fixed in
  • 1.123.27
  • 2.13.3
  • 2.14.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade n8n to version 1.123.27, 2.13.3, or 2.14.1 or later, where the vulnerability is fixed. No other mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-56356 is a stored cross-site scripting (XSS) vulnerability in n8n affecting the Chat Trigger node's Custom CSS field. The flaw arises from improper sanitization due to a misconfiguration of the sanitize-html library. Authenticated users with workflow modification permissions can inject malicious JavaScript that executes when other users visit the public chat page. The vulnerability is fixed in versions 1.123.27, 2.13.3, and 2.14.1.

References

Community reviews

Loading reviews…