CVE-2026-56358: n8n · Cross-site Scripting
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.11.2 or 1.123.25 when convenient.
Data as of 29 Oct 2026, 18:49 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 5.4 |
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-06-24.
- Patch
- Available – fixed in 2.11.2, 1.123.25
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade n8n to 2.11.2 or 1.123.25; n8n to 2.11.2; n8n to 1.123.25.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
| n8nn8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official fixes by upgrading n8n to version 1.123.25 or later in the 1.x branch, or to version 2.11.2 or later in the 2.x branch. No other mitigations are indicated or necessary once patched.
Description
CVE-2026-56358 is a stored cross-site scripting (XSS) vulnerability in n8n affecting versions before 1.123.25 (1.x) and before 2.11.2 (2.x). The flaw exists in the Form Trigger node's CSS sanitization, allowing authenticated users with workflow creation permissions to inject malicious scripts. These scripts execute persistently for all visitors of the affected forms, potentially enabling form hijacking and phishing attacks. The vulnerability has a medium severity with a CVSS 4.0 score of 5.1. Fixes are available in versions 1.123.25 and 2.11.2 and later.