CVE-2026-71497: jhy jsoup · Cross-site Scripting
Affects jhy jsoupSource CVE Database V5
Not known to be exploited · CVSS 4.7 Medium : upgrade to 1.23.1 when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.23.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade jsoup and org.jsoup/jsoup to 1.23.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| jhyjsoup | Affected
| Fixed in
|
Mavenorg.jsoup/jsouppkg:maven/org.jsoup/jsoupOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade jsoup to version 1.23.1 or later, where this vulnerability is fixed. Avoid using custom Safelists that permit raw-text elements if upgrading is not immediately possible.
Description
A cross-site scripting (XSS) vulnerability exists in jsoup, a Java HTML parsing library, in versions from 1.14.3 up to but not including 1.23.1. The issue arises when the parser incorrectly handles malformed tag names ending with control characters, causing misparsing that can lead to active markup being emitted instead of inert text when using custom Safelists that allow certain raw-text elements. The built-in Safelists are not affected. This vulnerability has a medium severity score and is fixed in version 1.23.1.