CVE-2026-8155: BuddyPress (WordPress plugin) · Insecure Direct Object Reference
Affects BuddyPress (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 14.5.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 14.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade BuddyPress (WordPress plugin) to 14.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| BuddyPress | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict user roles and permissions carefully to limit access to the private messaging functionality. Monitor for vendor updates regarding a security patch for BuddyPress version 14.5.0 or later.
Description
CVE-2026-8155 is a medium severity vulnerability in the BuddyPress WordPress plugin before version 14.5.0. It allows any authenticated user with Subscriber or higher privileges to bypass authorization controls on private messaging endpoints. This flaw enables unauthorized reading, modification, or deletion of other users' private messages.