CVE-2026-87854: Subscriptions for WooCommerce (WordPress plugin) · Information Exposure
Affects Subscriptions for WooCommerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.0.3 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade Subscriptions for WooCommerce (WordPress plugin) to 2.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Subscriptions for WooCommerce | Affected
| Fixed in
|
AI-suggested
A fixed version 2.0.3 or later is available that corrects the validation of the shared secret. Users should upgrade to version 2.0.3 or later to remediate this vulnerability. No additional mitigation steps are indicated.
Description
CVE-2026-87854 is an information exposure vulnerability in the Subscriptions for WooCommerce WordPress plugin versions before 2.0.3. The plugin fails to properly validate the shared secret for a REST endpoint, allowing unauthenticated users to access the full list of store subscriptions. Exposed data includes customer usernames, product names, recurring amounts, and payment dates.