Skip to main content
VulnerabilityPublished

CVE-2026-91097: HP Linux Imaging and Printing Software (HPLIP) · Out-of-bounds Write

Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.0 High : upgrade to 3.26.6 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade hp/hplip to 3.26.6.

Affected software

ProductAffectedFixed in
HP Inc.HP Linux Imaging and Printing Software (HPLIP)Affected
  • <3.26.6
Fixed in–
Hphp/hplippkg:deb/hp/hplipOther threatsAffected
  • <3.26.6
Fixed in
  • 3.26.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

HP has remediated this vulnerability in HPLIP version 3.26.6. Users should upgrade to version 3.26.6 or later to mitigate this issue. No other mitigation or temporary fixes are indicated. There are no known exploits in the wild currently.

Description

CVE-2026-91097 is a high-severity vulnerability in HP Linux Imaging and Printing Software (HPLIP) involving an out-of-bounds write (CWE-787). This flaw affects versions prior to 3.26.6 and could allow remote attackers to cause denial of service, escalate privileges, execute code remotely, disclose information, or modify files without authorization under certain conditions. HP has identified and remediated this and other vulnerabilities in HPLIP. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…