CVE-2026-91101: HP Linux Imaging and Printing Software (HPLIP) · Improper Validation of Array Index
Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5
Not known to be exploited · CVSS 5.1 Medium · fixed in 3.26.6 : update HP Linux Imaging and Printing Software (HPLIP) when convenient.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.26.6
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HP Inc.HP Linux Imaging and Printing Software (HPLIP) | Affected
| Fixed in– |
AI-suggested
A fix is available in HP Linux Imaging and Printing Software version 3.26.6. Users should upgrade to version 3.26.6 or later to remediate this vulnerability.
Description
CVE-2026-91101 is a medium severity vulnerability in HP Linux Imaging and Printing Software (HPLIP) caused by improper validation of array indexes (CWE-129). It affects versions prior to 3.26.6. The flaw could allow remote code execution, privilege escalation, denial of service, information disclosure, or unauthorized file modification under certain conditions. HP has identified and remediated multiple vulnerabilities in HPLIP, including this one.