Skip to main content
VulnerabilityPublished

CVE-2026-91103: HP Linux Imaging and Printing Software (HPLIP) · Integer Underflow

Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.26.6 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.26.6
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade hp/hplip to 3.26.6.

Affected software

ProductAffectedFixed in
HP Inc.HP Linux Imaging and Printing Software (HPLIP)Affected
  • <3.26.6
Fixed in–
Hphp/hplippkg:deb/hp/hplipOther threatsAffected
  • <3.26.6
Fixed in
  • 3.26.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

HP has remediated this vulnerability in HPLIP version 3.26.6. Users and administrators should upgrade to version 3.26.6 or later to address this issue. No additional mitigation actions are indicated by the vendor advisory.

Description

CVE-2026-91103 is an integer underflow vulnerability (CWE-191) in HP Linux Imaging and Printing Software (HPLIP) versions before 3.26.6. HP has identified and fixed multiple vulnerabilities in HPLIP that could allow remote code execution, privilege escalation, denial of service, information disclosure, or unauthorized file modification under certain conditions. The CVSS 4.0 base score is 5.1, indicating a medium severity level.

References

Community reviews

Loading reviews…