CVE-2026-91099: HP Linux Imaging and Printing Software (HPLIP) · UNIX symbolic link (symlink) following
Affects HP Linux Imaging and Printing Software (HPLIP)Source CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.26.6 when convenient.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.26.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu ubuntu/hplip package to 3.26.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HP Inc.HP Linux Imaging and Printing Software (HPLIP) | Affected
| Fixed in– |
Ubuntuubuntu/hplippkg:deb/ubuntu/hplipOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
HP has remediated these vulnerabilities in HPLIP version 3.26.6. Users should upgrade to version 3.26.6 or later to mitigate the risk. No additional mitigation guidance is provided in the vendor advisory data. Patch status is confirmed as fixed in 3.26.6.
Description
CVE-2026-91099 is a medium severity vulnerability in HP Linux Imaging and Printing Software (HPLIP) involving symbolic link (symlink) following (CWE-61). Multiple vulnerabilities were identified and remediated by HP affecting several components that could allow remote code execution, privilege escalation, denial of service, information disclosure, or unauthorized file modification under certain conditions. The affected versions are those prior to 3.26.6. The CVSS 4.0 base score is 5.1, indicating a medium impact. No known exploits are reported in the wild. HP has remediated these issues, but no direct patch link is provided in the data.