functype-mcp-server: MCP `set_functype_version` Package Alias RCE via Unsanitized pnpm install + Dynamic Import
Affects functype-mcp-serverSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to 1.4.4 soon.
Data as of 2 Nov 2026, 20:17 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.8 |
|---|
- Patch
- Available – fixed in 1.4.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade functype-mcp-server to 1.4.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmfunctype-mcp-server | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in version 1.4.4 that fixes this vulnerability. Users should upgrade to version 1.4.4 or later to remediate the issue. Until patched, avoid exposing the set_functype_version tool to untrusted inputs or unauthenticated users. The vendor advisory confirms the availability of an official fix.
Description
The functype-mcp-server contains a high-severity remote code execution vulnerability (CVE-2026-59176) in its set_functype_version tool. This tool accepts an unsanitized version string that is directly interpolated into an npm package specifier and installed via pnpm without validation. An attacker can exploit this by supplying a malicious package alias, causing the server to install and dynamically import attacker-controlled code, resulting in full RCE with server process privileges. The vulnerability affects versions prior to 1.4.4 and is patched in version 1.4.4.
References
- github.com/jordanburke/functype/security/advisories/GHSA-wcjj-9m6g-2fr2 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59176 (opens in a new tab)
- github.com/jordanburke/functype/commit/c0d58ad9c2a7d15c6117bd3adbbd75de37317dcf (opens in a new tab)
- github.com/jordanburke/functype (opens in a new tab)
- github.com/jordanburke/functype/releases/tag/v1.4.4 (opens in a new tab)