Skip to main content
CVE-2026-110859VulnerabilityPublished

legit · GitPython: arbitrary file read via attacker-controlled branch name in `Head.checkout()` (incomplete fix of

Affects legitSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110859· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.2.0.post0_16 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.0.post0_16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade legit to 1.2.0.post0_16.

Affected software

ProductAffectedFixed in
Homebrewlegitpkg:brew/legitOther threatsAffected
  • >=0.1.0 <1.2.0.post0_16
Fixed in
  • 1.2.0.post0_16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 1.2.0.post0_16 and later. Users should upgrade to this version or newer to remediate the vulnerability. The vendor advisory confirms the patch status. Until upgraded, avoid cloning repositories from untrusted sources or avoid calling Head.checkout() on branches from untrusted repositories.

Description

GitPython versions up to 3.1.62 contain a vulnerability in the Head.checkout() method where an attacker-controlled branch name can be used to inject arbitrary file read commands. This occurs because the branch name positional argument is not properly sanitized before being passed to the underlying git checkout command, allowing an attacker to read sensitive files such as /etc/passwd. The issue arises from an incomplete fix of previous advisories, where only keyword arguments were guarded but not positional arguments. The vulnerability has a CVSS 3.1 score of 7.5 (High).

References

Community reviews

Loading reviews…