Skip to main content
CVE-2026-110858VulnerabilityPublished

Legit: GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary command

Affects legitSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110858· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.2.0.post0_16 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.0.post0_16
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade legit to 1.2.0.post0_16.

Affected software

ProductAffectedFixed in
Homebrewlegitpkg:brew/legitOther threatsAffected
  • >=1.2.0.post0_3 <1.2.0.post0_16
Fixed in
  • 1.2.0.post0_16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of GitPython is available in 1.2.0.post0_16 that properly validates the positional refspec argument against unsafe options. Users should upgrade to this version or later. Until upgraded, avoid passing untrusted or attacker-controlled data as the refspec argument to Remote.pull().

Description

GitPython's Remote.pull() method improperly handles its positional refspec argument, allowing an attacker to supply a crafted refspec that bypasses the unsafe-option guard. This leads to arbitrary command execution with the privileges of the calling process when using local-path or SSH transports. The vulnerability affects versions from 1.2.0.post0_3 up to but not including 1.2.0.post0_16 and has been assigned CVE-2026-110858. A fix is available in version 1.2.0.post0_16.

References

Community reviews

Loading reviews…