Skip to main content
VulnerabilityPublished Updated

CVE-2026-109089: libXi security update

Affects libXiSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-109089· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.7.10-8.el9_8.3 soon.

Data as of 3 Nov 2026, 12:47 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (suse)CVSS 3.17.5
Patch
Available – fixed in 1.7.10-8.el9_8.3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the AlmaLinux to 1.7.10-8.el9_8.3.

Affected software

ProductAffectedFixed in
AlmaLinux 9libXiAffected
  • <1.7.10-8.el9_8.3
Fixed in
  • 1.7.10-8.el9_8.3
AlmaLinux 9libXi-develAffected
  • <1.7.10-8.el9_8.3
Fixed in
  • 1.7.10-8.el9_8.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libXi version 1.7.10-8.el9_8.3. Users of affected Red Hat Enterprise Linux 9 systems should apply this update promptly. Refer to the Red Hat advisory (RHSA-2026:93439) and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps.

Description

A heap-based buffer overflow vulnerability (CVE-2026-109089) exists in the X.Org X11 libXi runtime library, specifically in the DEVICE_RESOLUTION handling. This flaw could allow arbitrary code execution. An update fixing this issue is available in libXi version 1.7.10-8.el9_8.3 for Red Hat Enterprise Linux 9 and related variants.

References

Community reviews

Loading reviews…