Skip to main content
VulnerabilityPublished

CVE-2026-102325: webkit2gtk3 security update

Affects webkit2gtk3Source GCVE Database

0
Compare
Authoritative record:CVE-2026-102325· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.54.2-0.el9_8.2 when convenient.

Data as of 5 Nov 2026, 01:42 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.54.2-0.el9_8.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the AlmaLinux to 2.54.2-0.el9_8.2.

Affected software

ProductAffectedFixed in
AlmaLinux 9webkit2gtk3Affected
  • <2.54.2-0.el9_8.2
Fixed in
  • 2.54.2-0.el9_8.2
AlmaLinux 9webkit2gtk3-develAffected
  • <2.54.2-0.el9_8.2
Fixed in
  • 2.54.2-0.el9_8.2
AlmaLinux 9webkit2gtk3-jscAffected
  • <2.54.2-0.el9_8.2
Fixed in
  • 2.54.2-0.el9_8.2
AlmaLinux 9webkit2gtk3-jsc-develAffected
  • <2.54.2-0.el9_8.2
Fixed in
  • 2.54.2-0.el9_8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in webkit2gtk3 version 2.54.2-0.el9_8.2 for Red Hat Enterprise Linux 9 and related distributions. Users should apply this update promptly to remediate the issues. No additional mitigations are specified by the vendor advisory.

Description

A security update for webkit2gtk3 addresses multiple vulnerabilities in the Skia graphics library component used by chromium-browser within WebKitGTK. These include use-after-free, cross-origin data disclosure, information disclosure, integer overflow, out-of-bounds read, memory corruption, and improper input validation issues. The vulnerabilities affect versions of webkit2gtk3 prior to 2.54.2-0.el9_8.2. A fixed version 2.54.2-0.el9_8.2 is available from Red Hat.

References

Community reviews

Loading reviews…