CVE-2024-5430: GitLab · Improper Access Control
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.1.1 : update gitlab when convenient.
Data as of 26 Oct 2026, 09:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.1.1, 17.0.3, 16.11.5
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.1.1, 17.0.3 or 16.11.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GitLab CE/EE to versions 16.11.5, 17.0.3, or 17.1.1 or later where this vulnerability has been fixed. Since a patch is available, applying the official fix is the recommended remediation.
Description
GitLab CE/EE versions from 16.10 up to but excluding 16.11.5, from 17.0 up to but excluding 17.0.3, and from 17.1 up to but excluding 17.1.1 contain an improper access control vulnerability. This flaw allows a project maintainer to delete the merge request approval policy via GraphQL, which should be restricted. The issue has been addressed in the specified fixed versions.