Skip to main content
CVE-2024-3958VulnerabilityPublished Updated

CVE-2024-3958: Improper Control of Generation of Code ('Code Injection') in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.2.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 07:57 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.2.2, 17.1.4, 17.0.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 17.2.2, 17.1.4 or 17.0.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • <17.0.6
  • >=17.1.0 <17.1.4
  • >=17.2.0 <17.2.2
Fixed in
  • 17.0.6
  • 17.1.4
  • 17.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to version 17.0.6 or later, 17.1.4 or later, or 17.2.2 or later to remediate this issue. Applying these official fixes will prevent exploitation of this code injection vulnerability.

Description

CVE-2024-3958 is a code injection vulnerability in GitLab CE/EE that affects versions before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. The issue involves a discrepancy between the web application display and the git command line interface, which can be abused to social engineer users into cloning untrusted code. This vulnerability has a medium severity rating and a patch is available.

References

Community reviews

Loading reviews…