Skip to main content
VulnerabilityPublished

CVE-2026-77147: Apache Syncope · Code Injection

Affects syncope-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-77147· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 4.1.3 : update syncope-core when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.3, 4.0.8, 3.0.17
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade org.apache.syncope/syncope-core to 4.1.3, 4.0.8 or 3.0.17.

Affected software

ProductAffectedFixed in
Mavenorg.apache.syncope/syncope-corepkg:maven/org.apache.syncope/syncope-coreOther threatsAffected
  • >=3.0.0-M0 <3.0.17
  • >=4.0.0-M0 <4.0.8
  • >=4.1.0-M0 <4.1.3
Fixed in
  • 3.0.17
  • 4.0.8
  • 4.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Syncope to versions 4.0.8 or 4.1.3, which contain fixes for this vulnerability. No other mitigation or temporary workaround is indicated in the available data.

Description

Apache Syncope contains a code injection vulnerability (CVE-2026-77147) that allows an administrator with sufficient privileges to create a malicious Groovy Command class, bypassing the Groovy security sandbox. This affects versions from 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.7, and 4.1.0-M0 through 4.1.2. Upgrading to versions 4.0.8 or 4.1.3 mitigates this issue.

References

Community reviews

Loading reviews…