CVE-2024-2434: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited · 23% EPSS · fixed in 16.11.1 : patch gitlab soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 23.1% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.11.1, 16.10.4, 16.9.6
Exploitation evidence
Disclosed: evidence found.
CVE published 27 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade gitlab to 16.11.1, 16.10.4 or 16.9.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading GitLab to versions 16.9.6, 16.10.4, or 16.11.1 or later. Since a patch is available, remediation should be performed promptly to mitigate the risk.
Description
GitLab versions 16.9 prior to 16.9.6, 16.10 prior to 16.10.4, and 16.11 prior to 16.11.1 contain a path traversal vulnerability. This flaw allows an attacker to bypass pathname restrictions, potentially leading to denial of service (DoS) and unauthorized reading of restricted files. The issue affects both GitLab CE and EE editions. A patch is available to address this vulnerability.