Skip to main content
VulnerabilityPublished Updated

CVE-2024-4901: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · 33% EPSS · fixed in 17.1.1 : patch gitlab soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
33.0% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1.1, 17.0.3, 16.11.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.1.1, 17.0.3 or 16.11.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.9.0 <16.11.5
  • >=17.0.0 <17.0.3
  • >=17.1.0 <17.1.1
Fixed in
  • 16.11.5
  • 17.0.3
  • 17.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab to versions 16.11.5 or later, 17.0.3 or later, or 17.1.1 or later to remediate this issue. Applying these official fixes will prevent exploitation of the stored XSS vulnerability.

Description

A stored cross-site scripting (XSS) vulnerability exists in GitLab Community and Enterprise Editions. The flaw affects versions from 16.9 up to but not including 16.11.5, 17.0 up to but not including 17.0.3, and 17.1 up to but not including 17.1.1. The vulnerability arises when malicious commit notes are imported into a project, allowing injection of malicious scripts during web page generation.

References

Community reviews

Loading reviews…