CVE-2025-0555: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.9.1 soon.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.9.1
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.9.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab Enterprise Edition to version 17.9.1 or later, or to the respective fixed versions 17.7.6 or 17.8.4 as applicable. Applying the official fix will remediate the vulnerability.
Description
A Cross Site Scripting (XSS) vulnerability exists in GitLab Enterprise Edition affecting versions from 16.6 up to but not including 17.9.1. This flaw allows attackers to bypass security controls and execute arbitrary scripts in users' browsers under specific conditions. The vulnerability is rated as high severity. A patch is available to remediate this issue.