Skip to main content
VulnerabilityPublished Updated

CVE-2024-4278: GitLab · Incorrect Synchronization

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.4.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 09:15 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.4.1, 17.3.4, 17.2.8

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.4.1, 17.3.4 or 17.2.8.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.5.0 <17.2.8
  • >=17.3.0 <17.3.4
  • >=17.4.0 <17.4.1
Fixed in
  • 17.2.8
  • 17.3.4
  • 17.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading affected GitLab EE instances to versions 17.2.8, 17.3.4, or 17.4.1 or later. Applying these updates will remediate the information disclosure issue. No additional mitigation steps are indicated by the vendor advisory.

Description

An information disclosure vulnerability in GitLab EE allows a maintainer to obtain a Dependency Proxy password by editing a specific Dependency Proxy setting. This issue affects GitLab EE versions from 16.5 up to but not including 17.2.8, from 17.3 up to but not including 17.3.4, and from 17.4 up to but not including 17.4.1. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…