Skip to main content
VulnerabilityPublished Updated

CVE-2025-71088: linux-aws-6.17, linux-gcp, linux-gcp-6.17 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.17.0-1017.17~24.04.1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1017.17~24.04.1, 6.17.0-1018.19~24.04.1, 6.17.0-1018.19

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu to 6.17.0-1017.17~24.04.1 (linux-aws-6.17 package) or 6.17.0-1018.19~24.04.1 (linux-gcp-6.17 package) or 6.17.0-1018.19 (linux-gcp package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1018.19
Fixed in
  • 6.17.0-1018.19
Ubuntu 24.04 LTSlinux-aws-6.17pkg:deb/ubuntu/linux-aws-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1017.17~24.04.1
Fixed in
  • 6.17.0-1017.17~24.04.1
Ubuntu 24.04 LTSlinux-gcp-6.17pkg:deb/ubuntu/linux-gcp-6.17?arch=source&distro=nobleOther threatsAffected
  • <6.17.0-1018.19~24.04.1
Fixed in
  • 6.17.0-1018.19~24.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. The fixed kernel versions are 6.17.0-1017.17~24.04.1, 6.17.0-1018.19~24.04.1, and 6.17.0-1018.19. Users should update their Linux kernel packages to these versions or later and reboot their systems to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8374-1 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel versions including linux-aws-6.17, linux-gcp, and linux-gcp-6.17. These include flaws in cryptographic operations, socket buffer handling, race conditions, and AppArmor notification processing. Local attackers could exploit these issues to escalate privileges, escape containers, cause kernel panics, resource exhaustion, information disclosure, or kernel memory corruption. The vulnerabilities affect various subsystems such as cryptographic API, networking, memory management, and security modules. Fixes have been released in updated kernel versions.

References

Community reviews

Loading reviews…