Skip to main content
VulnerabilityPublished Updated

CVE-2025-10263: linux-aws-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-10263· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 6.8.0-1065.68+fips1 as a priority.

Data as of 6 Nov 2026, 14:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-1065.68+fips1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the Ubuntu linux-aws-fips package to 6.8.0-1065.68+fips1.

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 24.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1065.68+fips1
Fixed in
  • 6.8.0-1065.68+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in linux-aws-fips version 6.8.0-1065.68+fips1. Users should apply this update promptly and reboot their systems to ensure all changes take effect. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the official Ubuntu security notice USN-8817-2 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for AWS FIPS systems, including a critical issue affecting some Arm processors. This issue allows a local attacker to write to memory after permission has been revoked by exploiting a race condition in translation lookaside buffer (TLB) invalidation. Additional flaws affect various kernel subsystems such as network drivers, InfiniBand, and IPv4/IPv6 networking. These vulnerabilities could allow attackers to bypass memory protections or escalate privileges. A security update is available that addresses these issues.

References

Community reviews

Loading reviews…