CVE-2025-21709: linux-aws vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade to 6.8.0-1061.64 soon.
Data as of 28 Oct 2026, 05:11 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1061.64
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-aws package to 6.8.0-1061.64.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch addressing these vulnerabilities is available in linux-aws kernel version 6.8.0-1061.64. Users should update their systems to this version or later and reboot to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules are required after the update. Follow the official Ubuntu security notice USN-8595-2 for detailed update instructions.
Description
Multiple security vulnerabilities affecting the linux-aws kernel for Ubuntu 24.04 LTS were discovered, including issues in AMD processors related to speculative execution, resource isolation, and entropy generation. Additionally, numerous flaws across various Linux kernel subsystems and drivers were identified that could allow local attackers to compromise system integrity or confidentiality. These issues have been addressed in kernel version 6.8.0-1061.64 and later.
References
- ubuntu.com/security/notices/USN-8595-2 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21709 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22116 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38426 (opens in a new tab)
- ubuntu.com/security/CVE-2025-39764 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40135 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40150 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54505 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2025-62626 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68175 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68334 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71152 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71161 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71203 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71221 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71269 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71287 (opens in a new tab)