CVE-2025-21709: linux-azure-fde vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade to 6.8.0-1062.69 soon.
Data as of 28 Oct 2026, 05:11 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1062.69
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-azure-fde package to 6.8.0-1062.69.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading to linux-azure-fde version 6.8.0-1062.69 or later. The vendor advisory (https://ubuntu.com/security/notices/USN-8607-1) provides details on the update. Applying this official fix mitigates the described vulnerabilities.
Description
Multiple security vulnerabilities were discovered in the linux-azure-fde kernel, affecting various AMD processors and numerous Linux kernel subsystems. These include speculative execution data leakage on some AMD processors, privilege escalation on AMD Zen 2 processors due to improper resource isolation, and entropy issues on AMD Zen 5 processors affecting RDSEED instruction randomness. Additionally, numerous flaws across a wide range of kernel architectures and drivers could allow attackers to compromise system integrity or confidentiality. A patch addressing these issues is available in version 6.8.0-1062.69.
References
- ubuntu.com/security/notices/USN-8607-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21709 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22116 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38426 (opens in a new tab)
- ubuntu.com/security/CVE-2025-39764 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40005 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40135 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40150 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54505 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2025-62626 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68175 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68334 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71152 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71161 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71203 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71221 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71229 (opens in a new tab)