Skip to main content
VulnerabilityPublished Updated

CVE-2025-21709: linux-fips, linux-lowlatency, linux-lowlatency-hwe-6.8, linux-oracle vulnerabilities

Affects Linux kernelSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-136.136.2~22.04.1 : patch Linux kernel soon.

Data as of 28 Oct 2026, 05:11 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0-136.136.2~22.04.1, 6.8.0-136.136.2, 6.8.0-1058.61 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-lowlatencypkg:deb/ubuntu/linux-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-136.136.2
Fixed in
  • 6.8.0-136.136.2
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1058.61
Fixed in
  • 6.8.0-1058.61
Ubuntu Pro FIPS-updates 24.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-136.136+fips2
Fixed in
  • 6.8.0-136.136+fips2
Ubuntu 22.04 LTSlinux-lowlatency-hwe-6.8pkg:deb/ubuntu/linux-lowlatency-hwe-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-136.136.2~22.04.1
Fixed in
  • 6.8.0-136.136.2~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately. The fixed versions include 6.8.0-136.136.2~22.04.1, 6.8.0-136.136.2, 6.8.0-1058.61, and 6.8.0-136.136+fips2. After applying the update, a system reboot is required to complete remediation. Due to ABI changes, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8574-2 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting various AMD processors and numerous kernel subsystems. These include speculative execution data leakage, privilege escalation via operation cache resource isolation flaws, and entropy issues in RDSEED instruction handling. The update addresses these issues across a wide range of architectures and kernel components. Users must apply the provided patches and reboot to mitigate the risks.

References

Community reviews

Loading reviews…