Skip to main content
CVE-2024-58090VulnerabilityPublished Updated

linux, linux-aws, linux-gcp, linux-gke, linux-gkeop, linux-lowlatency, linux-lowlatency-hwe-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.8.0-84.84.1~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:36 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-84.84.1~22.04.1, 6.8.0-84.84, 6.8.0-1039.41 +4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-84.84
Fixed in
  • 6.8.0-84.84
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.41
Fixed in
  • 6.8.0-1039.41
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1040.42
Fixed in
  • 6.8.0-1040.42
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1036.40
Fixed in
  • 6.8.0-1036.40
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1023.25
Fixed in
  • 6.8.0-1023.25
Ubuntu 24.04 LTSlinux-lowlatencypkg:deb/ubuntu/linux-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-84.84.1
Fixed in
  • 6.8.0-84.84.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should update their Linux kernel packages to the fixed versions listed in the Ubuntu advisory USN-7764-1. After updating, a system reboot is required to apply the fixes. Due to an ABI change, recompilation and reinstallation of all third-party kernel modules is necessary to maintain system stability. Follow the vendor's update instructions carefully to ensure full remediation.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting numerous subsystems and architectures. These flaws could potentially allow an attacker to compromise affected systems. The issues impact a wide range of kernel components including ARM and x86 architectures, various device drivers, networking stacks, memory management, and more. Ubuntu has released patches addressing these vulnerabilities in several kernel versions. Users are advised to update to the fixed versions and reboot to apply the changes. Due to ABI changes, recompilation of third-party kernel modules may be necessary.

References

Community reviews

Loading reviews…