Skip to main content
VulnerabilityPublished Updated

CVE-2024-52559: linux, linux-aws, linux-lowlatency, linux-lowlatency-hwe-6.8, linux-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52559· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 6.8.0-78.78.1~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Contested

Scorers differ by 2 or more points
CVSS scores by source
CNA (Linux)CVSS 3.17.8
CISA-ADPCVSS 3.15.5
Patch
Available – fixed in 6.8.0-78.78.1~22.04.1, 6.8.0-78.78, 6.8.0-1035.37 +2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-78.78
Fixed in
  • 6.8.0-78.78
Ubuntu 24.04 LTSlinux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1035.37
Fixed in
  • 6.8.0-1035.37
Ubuntu 24.04 LTSlinux-lowlatencypkg:deb/ubuntu/linux-lowlatency?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-78.78.1
Fixed in
  • 6.8.0-78.78.1
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.1-1030.31
Fixed in
  • 6.8.1-1030.31
Ubuntu 22.04 LTSlinux-lowlatency-hwe-6.8pkg:deb/ubuntu/linux-lowlatency-hwe-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-78.78.1~22.04.1
Fixed in
  • 6.8.0-78.78.1~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security updates provided by Ubuntu as detailed in advisory USN-7703-1. Update to the fixed kernel versions 6.8.0-78.78.1~22.04.1, 6.8.0-78.78, 6.8.0-1035.37, 6.8.0-78.78.1, or 6.8.1-1030.31 depending on your kernel flavor. After updating, reboot the system to activate the patched kernel. Due to ABI changes, recompile and reinstall any third-party kernel modules. No other specific mitigations are indicated beyond applying these official patches.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting a wide range of subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities impact various kernel components including architectures (ARM64, PowerPC, x86), device drivers, networking protocols, filesystems, and kernel subsystems. Fixes have been released for affected Ubuntu Linux kernel packages, and users are advised to update and reboot to apply these patches.

References

Community reviews

Loading reviews…