CVE-2025-21709: linux-oracle-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade to 6.8.0-1058.61~22.04.1 soon.
Data as of 28 Oct 2026, 05:11 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1058.61~22.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 23 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu linux-oracle-6.8 package to 6.8.0-1058.61~22.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 22.04 LTSlinux-oracle-6.8pkg:deb/ubuntu/linux-oracle-6.8?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing these vulnerabilities is available in linux-oracle-6.8.0-1058.61~22.04.1. Users should apply this update promptly and reboot their systems to ensure all changes take effect. Due to an ABI change, recompilation and reinstallation of any third-party kernel modules are required after the update. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8595-1 for detailed upgrade instructions.
Description
Multiple security vulnerabilities affecting the linux-oracle-6.8 kernel have been identified and addressed. These include speculative execution flaws in AMD processors that could expose sensitive data, privilege escalation risks due to improper isolation in AMD Zen 2 processors, and entropy handling issues in AMD Zen 5 processors affecting RDSEED instruction outputs. Additionally, numerous security issues across various Linux kernel subsystems and drivers have been fixed. These vulnerabilities could allow local attackers to compromise system confidentiality, integrity, or escalate privileges. A patch is available and upgrading to linux-oracle-6.8.0-1058.61~22.04.1 or later is recommended.
References
- ubuntu.com/security/notices/USN-8595-1 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21709 (opens in a new tab)
- ubuntu.com/security/CVE-2025-22116 (opens in a new tab)
- ubuntu.com/security/CVE-2025-38426 (opens in a new tab)
- ubuntu.com/security/CVE-2025-39764 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40135 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40150 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54505 (opens in a new tab)
- ubuntu.com/security/CVE-2025-54518 (opens in a new tab)
- ubuntu.com/security/CVE-2025-62626 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68175 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68334 (opens in a new tab)
- ubuntu.com/security/CVE-2025-68736 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71152 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71161 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71203 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71221 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71269 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71287 (opens in a new tab)