CVE-2025-40005: linux-raspi-realtime vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-2049.50 soon.
Data as of 3 Nov 2026, 17:35 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-2049.50
Exploitation evidence
Disclosed: evidence found.
CVE published 6 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-raspi-realtime package to 6.8.0-2049.50.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating to Linux kernel version 6.8.0-2049.50 or later. After applying the update, a system reboot is required to complete remediation. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Users should follow the vendor's update instructions as provided in the Ubuntu security notice USN-8492-3.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi Real-time systems affecting numerous subsystems and architectures. These issues could potentially allow an attacker to compromise the system. The vulnerabilities span a wide range of kernel components including architectures (ARM64, MIPS, PowerPC, x86), device drivers, filesystems, networking, and security modules. A patch addressing these vulnerabilities is available in version 6.8.0-2049.50.
References
- ubuntu.com/security/notices/USN-8492-3 (opens in a new tab)
- ubuntu.com/security/CVE-2025-40005 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71229 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71231 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71232 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71233 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71235 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71236 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71237 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71238 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71239 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71265 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71266 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71267 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71272 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71273 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71274 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71286 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71291 (opens in a new tab)
- ubuntu.com/security/CVE-2025-71292 (opens in a new tab)