Skip to main content
VulnerabilityPublished Updated

CVE-2024-53168: linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-53168· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 5.15.0-1079.82 soon.

Data as of 3 Nov 2026, 23:01 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (Linux)CVSS 3.17.8
CISA-ADPCVSS 3.17.8
Patch
Available – fixed in 5.15.0-1079.82
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu linux-raspi package to 5.15.0-1079.82.

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-1079.82
Fixed in
  • 5.15.0-1079.82

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in linux-raspi kernel version 5.15.0-1079.82. Users should update their systems using standard package management tools and reboot to apply the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Following the vendor's update instructions will mitigate the vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems, affecting GPU drivers and the Sun RPC protocol. These flaws could potentially allow an attacker to compromise the system. A patch fixing these issues is available in version 5.15.0-1079.82 of the linux-raspi kernel package. Users are advised to update and reboot their systems to apply the fixes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled after the update.

References

Community reviews

Loading reviews…