Skip to main content
VulnerabilityPublished Updated

CVE-2025-40018: linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade to 6.17.0-1006.6 soon.

Data as of 3 Nov 2026, 17:43 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-1006.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu linux-raspi package to 6.17.0-1006.6.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.6
Fixed in
  • 6.17.0-1006.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Update the linux-raspi kernel package to version 6.17.0-1006.6 or later as provided by the Ubuntu security notice USN-7920-2. After updating, reboot the system to apply changes. Due to an ABI change in the kernel update, recompile and reinstall any third-party kernel modules. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were identified in the Linux kernel for Raspberry Pi systems, specifically affecting the tracing infrastructure and Netfilter subsystems. These flaws could potentially allow an attacker to compromise the system. A patch addressing these issues is available in version 6.17.0-1006.6 of the linux-raspi kernel package. Users are advised to update and reboot their systems to apply the fixes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required.

References

Community reviews

Loading reviews…