Skip to main content
VulnerabilityPublished Updated

CVE-2025-40246: linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited : upgrade to 6.17.0-1010.10 soon.

Data as of 3 Nov 2026, 17:32 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.17.0-1010.10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu linux-raspi package to 6.17.0-1010.10.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1010.10
Fixed in
  • 6.17.0-1010.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Linux kernel version 6.17.0-1010.10. Users should update their systems to this version or later to address these vulnerabilities. After updating, a system reboot is required to apply all changes. Due to an ABI change, third-party kernel modules must be recompiled and reinstalled. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8094-5 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems, including issues in the AppArmor Linux kernel Security Module (LSM) that allow unprivileged local attackers to manipulate AppArmor profiles, potentially causing denial of service, exposure of kernel memory, local privilege escalation, or container escape. Additionally, AMD Zen 5 processors supporting the RDSEED instruction were found to improperly handle entropy, possibly allowing local attackers to influence random values, leading to confidentiality and integrity loss. Numerous other kernel subsystems and drivers were also affected by various security flaws.

References

Community reviews

Loading reviews…