Skip to main content
VulnerabilityPublished Updated

CVE-2025-54505: linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54505· Low 2.0

Not known to be exploited · CVSS 2.0 Low : upgrade to 7.0.0-1014.14 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1014.14
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu linux-raspi package to 7.0.0-1014.14.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=resoluteOther threatsAffected
  • <7.0.0-1014.14
Fixed in
  • 7.0.0-1014.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in Linux kernel version 7.0.0-1014.14 for Raspberry Pi systems. Users should apply the update promptly and reboot their systems to ensure all fixes take effect. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. Follow the vendor advisory at https://ubuntu.com/security/notices/USN-8488-2 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems, including a flaw in some AMD processors where data in the floating point divider unit was not properly cleared during speculative execution. These issues affect numerous kernel subsystems and could potentially allow a local attacker to expose sensitive information or compromise the system. A patch addressing these vulnerabilities is available and included in Linux kernel version 7.0.0-1014.14 for Raspberry Pi.

References

Community reviews

Loading reviews…