Skip to main content
VulnerabilityPublished Updated

CVE-2025-64174: Magento lts · OpenMage vulnerable to XSS in Admin Notifications

Affects openmage/magento-ltsSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64174· Medium 4.6

Not known to be exploited · CVSS 4.6 Medium : upgrade to 20.16.0 when convenient.

Data as of 4 Nov 2026, 18:37 UTC

CVSS 4.0 base score
4.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.04.6
Patch
Available – fixed in 20.16.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade openmage/magento-lts to 20.16.0.

Affected software

ProductAffectedFixed in
Packagistopenmage/magento-ltsAffected
  • <20.16.0
Fixed in
  • 20.16.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OpenMage version 20.16.0 that fixes this vulnerability. Users should upgrade to version 20.16.0 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.

Description

OpenMage versions prior to 20.16.0 contain a stored Cross-Site Scripting (XSS) vulnerability in the admin notification interface. This flaw arises from unescaped translation strings and URLs in the admin notification grid renderer, allowing an attacker with administrative or translation privileges to inject malicious JavaScript. The vulnerability is exploitable when browsing the affected admin notifications page, potentially executing arbitrary scripts in the victim's browser. A fix is available in version 20.16.0.

References

Community reviews

Loading reviews…