Next.js has a Middleware / Proxy bypass in App Router applications via segment-prefetch routes - Incomplete Fix
Affects nextSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 15.5.18 soon.
Data as of 4 Nov 2026, 04:27 UTC
Sources agree
| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|---|---|
| ADP (redhat-SADP) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 15.5.18, 16.2.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade next to 15.5.18; next to 16.2.6.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmnext | Affected
| Fixed in
|
| npmnext | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading Next.js to versions 15.5.18 or later in the 15.x series, or 16.2.6 or later in the 16.x series. Red Hat has released security advisories with errata providing fixes for this vulnerability. Users should apply these official updates promptly to remediate the issue. No additional mitigation steps are indicated beyond applying the patch.
Description
A vulnerability in Next.js App Router applications allows middleware or proxy bypass via segment-prefetch routes. This issue is an incomplete fix of CVE-2026-44575, specifically affecting middleware.ts when used with Turbopack. The vulnerability can lead to information disclosure due to middleware bypass. It affects Next.js versions from 15.2.0 up to but not including 15.5.18, and from 16.0.0 up to but not including 16.2.6. A patch is available in versions 15.5.18 and 16.2.6.
References
- github.com/vercel/next.js/security/advisories/GHSA-267c-6grr-h53f (opens in a new tab)
- github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-45109 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:34608 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37272 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:40974 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:54435 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-45109 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477190 (opens in a new tab)
- github.com/vercel/next.js (opens in a new tab)
- github.com/vercel/next.js/releases/tag/v15.5.18 (opens in a new tab)
- github.com/vercel/next.js/releases/tag/v16.2.6 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45109.json (opens in a new tab)
- vercel.com/changelog/next-js-may-2026-security-release (opens in a new tab)