CVE-2026-15176: nginx vulnerabilities
Affects nginxSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.1 High · fixed in 1.4.6-1ubuntu3.9+esm9 : patch nginx soon.
Data as of 6 Nov 2026, 04:05 UTC
- Patch
- Available – fixed in 1.4.6-1ubuntu3.9+esm9, 1.10.3-0ubuntu0.16.04.5+esm10, 1.14.0-0ubuntu1.11+esm5 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and users should update nginx packages to the fixed versions provided by Ubuntu Pro for their respective Ubuntu LTS releases. Standard system updates or applying the Ubuntu Pro Legacy Support add-on for older releases will remediate these vulnerabilities. No additional mitigation is required beyond applying these official updates.
Description
Multiple vulnerabilities in nginx as packaged for various Ubuntu LTS releases allow remote attackers to cause denial of service or potentially execute arbitrary code. These include improper handling of alias directives with rewrite rules, map directives using regex matching, HTTP/3 requests with proxy_request_buffering enabled, asynchronous file I/O with Server Side Includes, and SSL session ticket key management. The issues affect Ubuntu 14.04 LTS through 20.04 LTS and have been fixed in updated package versions.