Skip to main content
CVE-2025-23419VulnerabilityPublished Updated

Nginx: When multiple server blocks are configured to share the same IP address and port, an attacker can use session

Affects nginxSource GCVE Database

0
Compare
Authoritative record:CVE-2025-23419· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in 1.18.0-0ubuntu1.7 : update nginx when convenient.

Data as of 5 Nov 2026, 23:23 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.7% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.0-0ubuntu1.7, 1.18.0-6ubuntu14.6, 1.24.0-2ubuntu7.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Ubuntu nginx to 1.18.0-0ubuntu1.7 (package) or 1.18.0-6ubuntu14.6 (package) or 1.24.0-2ubuntu7.3 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.3
Fixed in
  • 1.24.0-2ubuntu7.3
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.6
Fixed in
  • 1.18.0-6ubuntu14.6
Ubuntu 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=focalOther threatsAffected
  • <1.18.0-0ubuntu1.7
Fixed in
  • 1.18.0-0ubuntu1.7
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.1-0ubuntu2 – 1.14.0-0ubuntu1.11+esm5
20 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.9.3-1ubuntu1 – 1.10.3-0ubuntu0.16.04.5+esm10
31 affected builds
Fixed in–
Ubuntu Pro 14.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 1.4.1-3ubuntu1 – 1.4.6-1ubuntu3.9+esm9
25 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update nginx packages to the fixed versions provided by Ubuntu: 1.18.0-0ubuntu1.7 for 20.04 LTS, 1.18.0-6ubuntu14.6 for 22.04 LTS, and 1.24.0-2ubuntu7.3 for 24.10. Applying these updates will remediate the vulnerability. Standard system updates will apply the necessary patches.

Description

Nginx versions prior to certain patched releases contain a vulnerability where multiple server blocks sharing the same IP address and port can allow an attacker to bypass client certificate authentication via TLS session resumption. This issue arises when TLS Session Tickets or SSL session cache are used in the default server performing client certificate authentication. The vulnerability affects specific Ubuntu package versions of nginx and has been fixed in updated package releases.

References

Community reviews

Loading reviews…